Apache を 2.2系から 2.4系に上げて大ごとになった(^^;

自社サーバの話。

現在稼働中の Apache 2.2.19 が、mod_rewrite や mod_proxy を使えるように make してなかったので、再インストールするついでにバージョン上げとくか・・・と軽く考えたのが失敗だった(^^;

2.2系から、2.4系ってけっこう大幅に変更がかかってんのね・・・

インストール自体は今までの Apache 同様にすぐ終わったんだけど(ソースからコンパイルした)、httpd.conf とか、2.2系のものをそのまま使うのって無理なんじゃね。
まあ、そのへんは既に有名な話みたいで、「Apache 使い」なら知っていて当然のようなんだが、ここのところ Apache のセットアップ案件ってなかったし、別件で忙しくて、その手の話題を全然追っかけてなかったんだわ・・・と言い訳しとく(笑)
もっとも、大事なサーバの Apache なら、2.4系にするなんてことせんけどね。2.2系の最新の 2.2.22 にしてたわな。

新しく設定ファイルを全部書きなおすんなら問題ないんだけど、ただ、うちのサーバも、テスト用に色々 VirtualHost 立ててるし、https サーバも動いてるし、出来ればそのまま 2.2.19 で使ってた設定ファイル使いたいのよ。

ちゅーことで、以下のような対応をして、取り敢えず BASIC 認証かけてるサイト以外は CGI や PHP も含めて動くようになった。

・機能がモジュールに切りだされていて、ちゃんと LoadModule しないとエラーになるもの多数。
 例えば、unixd_module をロードしておかないと Invalid command 'User' になるとか、mime_module をロードしておかないと、Invalid command 'AddHandler' になるとか。
 結局、うちの設定だと、以下のようなモジュールのロードが必要だった。

LoadModule unixd_module modules/mod_unixd.so
LoadModule access_compat_module modules/mod_access_compat.so
LoadModule authz_core_module modules/mod_authz_core.so
LoadModule userdir_module modules/mod_userdir.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule dir_module modules/mod_dir.so
LoadModule actions_module modules/mod_actions.so
LoadModule mime_module modules/mod_mime.so
LoadModule alias_module modules/mod_alias.so
LoadModule ssl_module modules/mod_ssl.so
LoadModule socache_shmcb_module modules/mod_socache_shmcb.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule cgid_module modules/mod_cgid.so

・Ignoring deprecated use of DefaultType なエラーになるので、httpd.conf から DefaultType text/plain の行は削除。

・NameVirtualHost has no effect and will be removed in the next release なエラーが出るので、extra/httpd-vhosts.conf から該当行を削除。

・extra/httpd-ssl.conf の SSLMutex 行は、Mutex default ssl-cache に変更。

まあ、こう書くと簡単なんだけど、実際には Invalid command になったディレクティブがどのモジュールに関係しているかとか、なかなかそのものズバリの資料がなくて苦労したわ。

後は、BASIC 認証のためのアクセスコントロール設定の記述が、

Order allow,deny
Allow from all

であれば、

Require all granted

のように修正しないといかんらしい。

いっぱいあるよ、そういう記述。全部直すのか。やれやれ。(ま、このサーバで公開しているのは、ごく内輪のメンバー向けサイトかテストサイトだけなので、気楽に修正していくけどねぇ~)

<追記>
BASIC 認証がうまくいってなかったのは、単純にまだ必要なモジュールがロードされてなかっただけだった。
Clip to Evernote

トラックバック(0)

このブログ記事を参照しているブログ一覧: Apache を 2.2系から 2.4系に上げて大ごとになった(^^;

このブログ記事に対するトラックバックURL: http://blog.netandfield.com/mt/mt-tb.cgi/2120

コメントする


画像の中に見える文字を入力してください。

このブログ記事について

このページは、shinodaが2012年5月23日 19:21に書いたブログ記事です。

ひとつ前のブログ記事は「平成24年度祖生地区ソフトボールリーグ戦がスタートした」です。

次のブログ記事は「Apache 2.4系移行苦労話(BASIC 認証編)」です。

最近のコンテンツはインデックスページで見られます。過去に書かれたものはアーカイブのページで見られます。

月別 アーカイブ

電気ウナギ的○○ mobile ver.

携帯版「電気ウナギ的○○」はこちら